App intermittently unavailable

Resolved in 3 hours

Incident timeline

Operational
Resolved
Though we're yet to see an all-clear from our server provider, we've seen much more stable traffic for nearly an hour and we're going to conclude this incident.
2022-08-24 01:47:28 UTC - over a year
Degraded performance
Monitoring
Some good news: we're starting to see traffic return to our servers. We'll monitor for a while to make sure things have stabilized before calling an all-clear on this one, but we're able to access MxU again.
2022-08-24 00:58:30 UTC - over a year
Outage
Monitoring
Unfortunately, we're still waiting on our server provider (Heroku) to fix their DNS outage that has taken many, many other applications down alongside MxU. We're closely monitoring things and will confirm here as soon as things are stable. We're so sorry for the extended downtime, and are grateful for your patience this evening.
2022-08-24 00:36:37 UTC - over a year
Outage
Monitoring
Our third-party server provider is still unable to accept requests due to a DNS issue. MxU will be mostly unavailable until that issue is resolved. We're monitoring and will let you know as soon as stability is restored. [Status updated to reflect that no requests were completing at this time in the outage]
2022-08-23 23:43:19 UTC - over a year
Outage
Investigating
A third party provider is experiencing an issue with DNS, causing requests to MxU to fail. We're investigating and tracking their updates. [Updated to reflect point in time where requests stopped completely]
2022-08-23 23:43:00 UTC - over a year
Partial outage
Monitoring
[Added later] At about 6:34PM Eastern this evening, our third party server provider's DNS issue began causing the majority of requests to MxU to fail.
2022-08-23 22:34:00 UTC - over a year